import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\.?(?:(?:\\d{1,3}[,. ])*\\d{1,3}(?:\\.\\d{2})?|\\d+\\.\\d+|\\d+)\\.?$";
final String string = "1,000\n"
+ "1000.00\n"
+ "1,000,000.00\n"
+ "2.000.000,00\n"
+ "123748\n"
+ "4 294 967 295,000\n"
+ "0.24\n"
+ ".24\n"
+ "24\n"
+ "24.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}