# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(Descrição:.{8})"
test_str = ("\n"
" Pagamento Eletrônico de Tributos/Contas de Consumo Bradesco \n"
" Comprovante de Pagamento \n\n"
" GUIA NACIONAL DE RECOLHIMENTO ESTADUAL - GNRE \n\n"
" Código de Barras: 85840011134 1 62370278120 4 16110902000 4 02006081262 6 \n\n"
" Empresa / Órgão: SEFAZ RIO DE JANEIRO - GNRE/RJ \n\n"
" NOSSO NUMERO 02000020060812 \n\n"
" Descrição: GNRE Data de Vencimento: 09/11/2016 \n\n"
" Data do Pagamento: 09/11/2016 \n\n"
" Valor Principal: R$ 1.113.462,37 \n\n"
" Valor de Juros: R$ 0,00 \n\n"
" Valor de Multa: R$ 0,00 Valor do Pagamento: R$ 1.113.462,37 \n\n"
" Autenticação Bancária: 095465354 \n\n"
" Núm . de Controle: 60100608868888950348801055 \n\n"
" ICMS-ST INTEREST DE SP PARA RJ 102016 \n\n"
" A GNRE - Guia Nacional de Recolhimento de Tributos Estaduais acima foi efetuada através do PTRB - Pagamento Eletrônico de \n"
" Tributos, dentro das condições especificadas. O lançamento consta no extrato da conta junto à agência 313-1, data de pagamento \n"
" 09/11/2016. \n"
" N° do Documento: 04370837900012016110900158 \n"
" Alô Bradesco – SAC – 0800 704 8383 Deficiente Auditivo – 0800 722 0099, atendimento 24 horas, 7 dias por semana. Ouvidoria – 0800 \n"
" 727 9933, atendimento de 2ª a 6ª feira das 8h às 18h, exceto feriados \n\n"
" Banco Bradesco S/A \n\n\n")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.