import Foundation
let pattern = #"(Descrição:.{8})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Pagamento Eletrônico de Tributos/Contas de Consumo Bradesco
Comprovante de Pagamento
GUIA NACIONAL DE RECOLHIMENTO ESTADUAL - GNRE
Código de Barras: 85840011134 1 62370278120 4 16110902000 4 02006081262 6
Empresa / Órgão: SEFAZ RIO DE JANEIRO - GNRE/RJ
NOSSO NUMERO 02000020060812
Descrição: GNRE Data de Vencimento: 09/11/2016
Data do Pagamento: 09/11/2016
Valor Principal: R$ 1.113.462,37
Valor de Juros: R$ 0,00
Valor de Multa: R$ 0,00 Valor do Pagamento: R$ 1.113.462,37
Autenticação Bancária: 095465354
Núm . de Controle: 60100608868888950348801055
ICMS-ST INTEREST DE SP PARA RJ 102016
A GNRE - Guia Nacional de Recolhimento de Tributos Estaduais acima foi efetuada através do PTRB - Pagamento Eletrônico de
Tributos, dentro das condições especificadas. O lançamento consta no extrato da conta junto à agência 313-1, data de pagamento
09/11/2016.
N° do Documento: 04370837900012016110900158
Alô Bradesco – SAC – 0800 704 8383 Deficiente Auditivo – 0800 722 0099, atendimento 24 horas, 7 dias por semana. Ouvidoria – 0800
727 9933, atendimento de 2ª a 6ª feira das 8h às 18h, exceto feriados
Banco Bradesco S/A
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)