package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\W`)
var str = `957 1486 0065`
var substitution = "\-"
fmt.Println(re.ReplaceAllString(str, substitution))
}