// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\W").unwrap();
let string = "957 1486 0065";
let substitution = "\\-";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}