import Foundation
let pattern = #"\W"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"957 1486 0065"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\-"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)