package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m){[^}]+}`)
var str = `Revenue for the period is {value="32", font="34"} and EBITDA is {value="12", font="34"} for 2022
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}