$re = '/{[^}]+}/m';
$str = 'Revenue for the period is {value="32", font="34"} and EBITDA is {value="12", font="34"} for 2022
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);