using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"=+[^=]+=+\n([\w\W]+\n)(?==+[^=]+=+\n)";
string input = @"== Title1 ==
.............
............. // Some texts
.............
End of Paragraph
===Title2 ===
.............
............. // Some texts
.............";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}