$re = '/=+[^=]+=+\n([\w\W]+\n)(?==+[^=]+=+\n)/m';
$str = '== Title1 ==
.............
............. // Some texts
.............
End of Paragraph
===Title2 ===
.............
............. // Some texts
.............';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);