re = /=+[^=]+=+\n([\w\W]+\n)(?==+[^=]+=+\n)/m
str = '== Title1 ==
.............
............. // Some texts
.............
End of Paragraph
===Title2 ===
.............
............. // Some texts
.............'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end