#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\d{2}/\d{2}/\d{4}"
Local $sString = "D¬ng ThÞ Anh 19/02/1992 TH12B 10.0 5.0" & @CRLF & _
"La C«ng TuÊn Anh 30/01/1995 TH12A 8.5 6.5" & @CRLF & _
"NguyÔn §øc Anh 14/10/1995 TH12B 10.0 5.5" & @CRLF & _
"Ph1m Tïng Anh 10/04/1994 HTTT11 1.0 4.5"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")