re = /\d{2}\/\d{2}\/\d{4}/
str = 'D¬ng ThÞ Anh 19/02/1992 TH12B 10.0 5.0
La C«ng TuÊn Anh 30/01/1995 TH12A 8.5 6.5
NguyÔn §øc Anh 14/10/1995 TH12B 10.0 5.5
Ph1m Tïng Anh 10/04/1994 HTTT11 1.0 4.5'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end