import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{2}/\\d{2}/\\d{4}";
final String string = "D¬ng ThÞ Anh 19/02/1992 TH12B 10.0 5.0\n"
+ "La C«ng TuÊn Anh 30/01/1995 TH12A 8.5 6.5\n"
+ "NguyÔn §øc Anh 14/10/1995 TH12B 10.0 5.5\n"
+ "Ph1m Tïng Anh 10/04/1994 HTTT11 1.0 4.5";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}