use strict;
my $str = '"var block = new MatchesBlock(\'page_competition_1_block_competition_matches_summary_5\', \'block_competition_matches_summary\', {"page":0,"bookmaker_urls":{"13":[{"link":"http:\\/\\/www.bet365.com\\/home\\/?affiliate=365_178981","name":"Bet 365"}]},"block_service_id":"competition_summary_block_competitionmatchessummary","round_id":42011,"outgroup":false,"view":2,"competition_id":13});"
';
my $regex = qr/MatchesBlock[^\{]+\K(.*})/p;
my $subst = '$1$2$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";