import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^/]+-(?:\\w+\\.v)?\\d+(?:\\.\\d+)*";
final String string = "/abc/def/hdk/database/dbclient/ibm/DB2Client-V97FP02.v01/sqllib/lib64\n"
+ "/abc/def/hdk/database/dbclient/ibm/DB2Client-V97FP02.v01/sqllib/misc\n"
+ "azn/external/curl-7.52.1/linux_g44.exe\n"
+ "store/software/ep/rpg/external/python27-2.7.1/lib";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}