const regex = new RegExp('[^/]+-(?:\\w+\\.v)?\\d+(?:\\.\\d+)*', 'gm')
const str = `/abc/def/hdk/database/dbclient/ibm/DB2Client-V97FP02.v01/sqllib/lib64
/abc/def/hdk/database/dbclient/ibm/DB2Client-V97FP02.v01/sqllib/misc
azn/external/curl-7.52.1/linux_g44.exe
store/software/ep/rpg/external/python27-2.7.1/lib`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}