$re = '~[^/]+-(?:\w+\.v)?\d+(?:\.\d+)*~m';
$str = '/abc/def/hdk/database/dbclient/ibm/DB2Client-V97FP02.v01/sqllib/lib64
/abc/def/hdk/database/dbclient/ibm/DB2Client-V97FP02.v01/sqllib/misc
azn/external/curl-7.52.1/linux_g44.exe
store/software/ep/rpg/external/python27-2.7.1/lib';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);