using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{3}[-]\d{9}[-]\d{3})";
string input = @"слово слово слово слово 000-000000000-000
не парсим раз два три 1234-2222-66666
парсим 555-222222222-000
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}