$re = '/(\d{3}[-]\d{9}[-]\d{3})/m';
$str = 'слово слово слово слово 000-000000000-000
не парсим раз два три 1234-2222-66666
парсим 555-222222222-000
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);