// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d{3}[-]\d{9}[-]\d{3})").unwrap();
let string = "слово слово слово слово 000-000000000-000
не парсим раз два три 1234-2222-66666
парсим 555-222222222-000
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}