import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(192\\.168\\.(1|2|10|11|12|20|21|22)\\..+)|(10\\.0\\.0\\.99)|(172\\.0\\.0\\.45)|(172\\.0\\.0\\.46)|(10\\.10\\.10\\.50)|(10\\.10\\.10\\.52)";
final String string = "192.168.189.999\n"
+ "192.168.22.3\n"
+ "192.168.10.10\n"
+ "192.168.1.1\n"
+ "10.0.0.99\n"
+ "10.10.10.50\n"
+ "10.10.10.51\n"
+ "10.10.10.52\n"
+ "10.10.10.53\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}