re = /(192\.168\.(1|2|10|11|12|20|21|22)\..+)|(10\.0\.0\.99)|(172\.0\.0\.45)|(172\.0\.0\.46)|(10\.10\.10\.50)|(10\.10\.10\.52)/m
str = '192.168.189.999
192.168.22.3
192.168.10.10
192.168.1.1
10.0.0.99
10.10.10.50
10.10.10.51
10.10.10.52
10.10.10.53
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end