const regex = /(192\.168\.(1|2|10|11|12|20|21|22)\..+)|(10\.0\.0\.99)|(172\.0\.0\.45)|(172\.0\.0\.46)|(10\.10\.10\.50)|(10\.10\.10\.52)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(192\\.168\\.(1|2|10|11|12|20|21|22)\\..+)|(10\\.0\\.0\\.99)|(172\\.0\\.0\\.45)|(172\\.0\\.0\\.46)|(10\\.10\\.10\\.50)|(10\\.10\\.10\\.52)', 'gm')
const str = `192.168.189.999
192.168.22.3
192.168.10.10
192.168.1.1
10.0.0.99
10.10.10.50
10.10.10.51
10.10.10.52
10.10.10.53
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}