using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"/([^_/]+)_[^/\s]*";
string input = @"2019/01/01/07/556662_cba3a4fc-cb8f-4150-859f-5f21a38373d0 kj /fafetff_
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}