re = /\/([^_\/]+)_[^\/\s]*/m
str = '2019/01/01/07/556662_cba3a4fc-cb8f-4150-859f-5f21a38373d0 kj /fafetff_
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end