package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)/([^_/]+)_[^/\s]*`)
var str = `2019/01/01/07/556662_cba3a4fc-cb8f-4150-859f-5f21a38373d0 kj /fafetff_
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}