#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\d)(\d)(?!\d)"
Local $sString = "1. 1-1 Prise en main de blender" & @CRLF & _
"2. 2-1 Présentation de la sculpture" & @CRLF & _
"3. 2-2 Sculpter le visage" & @CRLF & _
"4. 2-3 Retopologie : Créer la structure du visage" & @CRLF & _
"5. 2-4 Retopologie : Placer les vertices de face" & @CRLF & _
"6. 2-5 Retopologie : Placer les vertices de profil" & @CRLF & _
"7. 2-6 Finalisation de la tête" & @CRLF & _
"8. 2-7 Modéliser et placer les yeux" & @CRLF & _
"9. 2-8 Modéliser les cheveux" & @CRLF & _
"10. 2-9 Modéliser les cils et sourcils" & @CRLF & _
"11. 2-10 Modéliser l'intérieur de la bouche" & @CRLF & _
"12. 3-1 Préparer la modélisation du corps" & @CRLF & _
"13. 3-2 Modéliser le corps" & @CRLF & _
"14. 3-3 Modéliser les pieds" & @CRLF & _
"15. 3-4 Modéliser les mains" & @CRLF & _
"16. 3-5 Modéliser les doigts partie 1" & @CRLF & _
"17. 3-6 Modéliser les doigts partie 2" & @CRLF & _
"18. 3-7 Ajuster et préciser les bras" & @CRLF & _
"19. 3-8 Ajuster le corps pour préparer le raccord à la tête" & @CRLF & _
"20. 3-9 Raccorder le corps à la tête" & @CRLF & _
"21. 3-10 Ajuster la tête à l'aide du "Modifier" lattice" & @CRLF & _
"22. 4-1 Créer le pantalon" & @CRLF & _
"23. 4-2 Créer le T-shirt" & @CRLF & _
"24. 4-3 Créer les bottes" & @CRLF & _
"25. 4-4 Donner de l'épaisseur aux habits" & @CRLF & _
"26. 5-1 Texturer le pantalon" & @CRLF & _
"27. 5-2 Texturer le T-shirt" & @CRLF & _
"28. 5-3 Texturer les bottes" & @CRLF & _
"29. 5-4 Texturer les cheveux" & @CRLF & _
"30. 5-5 Faire un dégradé sur les cheveux" & @CRLF & _
"31. 5-6 Texturer les cils/sourcils" & @CRLF & _
"32. 5-7 Texturer les yeux" & @CRLF & _
"33. 5-8 Préparer le personnage au texturing" & @CRLF & _
"34. 5-9 Dépliage UV du personnage" & @CRLF & _
"35. 5-10 Préparer les images pour le texture paint" & @CRLF & _
"36. 5-11 Peindre le corps" & @CRLF & _
"37. 5-12 Peindre le visage" & @CRLF & _
"38. 5-13 Peindre les mains" & @CRLF & _
"39. 5-14 Peindre l'intérieur de la bouche et les lèvres" & @CRLF & _
"40. 5-15 Reliefs et spécularité du visage" & @CRLF & _
"41. 6-1 Parties délavées du pantalon" & @CRLF & _
"42. 6-2 Ajouter un Fresnel aux textures" & @CRLF & _
"43. 7-1 Créer l'armature" & @CRLF & _
"44. 7-2 Appliquer la symétrie du squelette" & @CRLF & _
"45. 7-3 Créer un contrôleur "Master"" & @CRLF & _
"46. 7-4 Créer une IK pour les jambes" & @CRLF & _
"47. 7-5 Créer une IK pour les bras" & @CRLF & _
"48. 7-6 Créer un contrôleur pour le regard" & @CRLF & _
"49. 7-7 Créer un contrôleur pour plier les doigts" & @CRLF & _
"50. 7-8 Appliquer les contrôleurs en symétrie" & @CRLF & _
"51. 7-9 Connecter l'armature au personnage" & @CRLF & _
"52. 7-10 Customiser les contrôleurs genoux et coudes" & @CRLF & _
"53. 7-11 Customiser le contrôleur "Master"" & @CRLF & _
"54. 7-12 Customiser les contrôleurs IK" & @CRLF & _
"55. 7-13 Customiser les contrôleurs de la colonne vertébrale" & @CRLF & _
"56. 7-14 Customiser les contrôleurs épaules, cou, tête" & @CRLF & _
"57. 7-15 Appliquer des couleurs aux groupes de "bones"" & @CRLF & _
"58. 7-16 Customiser les contrôleurs des doigts" & @CRLF & _
"59. 7-17 Faire suivre le regard" & @CRLF & _
"60. 7-18 Automatiser la fermeture des doigts" & @CRLF & _
"61. 7-19 Créer des drivers pour plier les doigts" & @CRLF & _
"62. 7-20 Corrections de la fermeture du poing" & @CRLF & _
"63. 7-21 Réduire la résolution du pantalon en conservant les détails dans la texture" & @CRLF & _
"64. 7-22 Réduire la résolution du T-shirt en conservant les détails dans la texture" & @CRLF & _
"65. 7-23 Préparer le personnage pour éviter les éventuels défauts liés aux habits" & @CRLF & _
"66. 8-1 Créer les expressions faciales" & @CRLF & _
"67. 8-2 Fermer les yeux" & @CRLF & _
"68. 8-3 Créer un driver pour la fermeture des yeux" & @CRLF & _
"69. 8-4 Finaliser l'expression de "colère" et lui créer un driver" & @CRLF & _
"70. 8-5 Faire briller les yeux" & @CRLF & _
"71. 9-1 Connecter les habits à l'armature et peindre les influences des os" & @CRLF & _
"72. 9-2 Créer le "Kameha"" & @CRLF & _
"73. 9-3 Placer la première pose du personnage" & @CRLF & _
"74. 9-4 Créer le mouvement de caméra du premier plan de notre animation" & @CRLF & _
"75. 9-5 Affiner les réglages et faire sourire le personnage" & @CRLF & _
"76. 9-6 Animer le mouvement du personnage" & @CRLF & _
"77. 9-7 Correction bug possible de texture des yeux" & @CRLF & _
"78. 9-8 Animer le "Kameha"" & @CRLF & _
"79. 9-9 Placer et animer la 2ème caméra" & @CRLF & _
"80. 9-10 Créer l'effet tremblement de la caméra" & @CRLF & _
"81. 9-11 Créer le mouvement des cheveux" & @CRLF & _
"82. 10-1 Créer le fond et les lumières" & @CRLF & _
"83. 10-2 Texturer le fond et régler la profondeur de champs des caméras" & @CRLF & _
"84. 10-3 Réglages de rendu" & @CRLF & _
"85. 10-4 Point sur l'export et explications lumières volumétriques" & @CRLF & _
"79. 9-9 Placer et animer[xnmjklxx]la 2ème caméra" & @CRLF & _
"80. 9-10 Créer l'effet tremblement de la caméra" & @CRLF & _
"81. 9-11 Créer le mouvement des cheveux" & @CRLF & _
"82. 10-1 Créer le[xwerrxxxxx]fond et les lumières" & @CRLF & _
"83. 10-2[xx]Texturer le fond et régler la profondeur de champs des caméras" & @CRLF & _
"84. 10-3 Réglages de rendu" & @CRLF & _
"85. 10-4 Point[xxxxtzzxxx]sur l'export et explications "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")