re = /(?<!\d)(\d)(?!\d)/m
str = '1. 1-1 Prise en main de blender
2. 2-1 Présentation de la sculpture
3. 2-2 Sculpter le visage
4. 2-3 Retopologie : Créer la structure du visage
5. 2-4 Retopologie : Placer les vertices de face
6. 2-5 Retopologie : Placer les vertices de profil
7. 2-6 Finalisation de la tête
8. 2-7 Modéliser et placer les yeux
9. 2-8 Modéliser les cheveux
10. 2-9 Modéliser les cils et sourcils
11. 2-10 Modéliser l\'intérieur de la bouche
12. 3-1 Préparer la modélisation du corps
13. 3-2 Modéliser le corps
14. 3-3 Modéliser les pieds
15. 3-4 Modéliser les mains
16. 3-5 Modéliser les doigts partie 1
17. 3-6 Modéliser les doigts partie 2
18. 3-7 Ajuster et préciser les bras
19. 3-8 Ajuster le corps pour préparer le raccord à la tête
20. 3-9 Raccorder le corps à la tête
21. 3-10 Ajuster la tête à l\'aide du "Modifier" lattice
22. 4-1 Créer le pantalon
23. 4-2 Créer le T-shirt
24. 4-3 Créer les bottes
25. 4-4 Donner de l\'épaisseur aux habits
26. 5-1 Texturer le pantalon
27. 5-2 Texturer le T-shirt
28. 5-3 Texturer les bottes
29. 5-4 Texturer les cheveux
30. 5-5 Faire un dégradé sur les cheveux
31. 5-6 Texturer les cils/sourcils
32. 5-7 Texturer les yeux
33. 5-8 Préparer le personnage au texturing
34. 5-9 Dépliage UV du personnage
35. 5-10 Préparer les images pour le texture paint
36. 5-11 Peindre le corps
37. 5-12 Peindre le visage
38. 5-13 Peindre les mains
39. 5-14 Peindre l\'intérieur de la bouche et les lèvres
40. 5-15 Reliefs et spécularité du visage
41. 6-1 Parties délavées du pantalon
42. 6-2 Ajouter un Fresnel aux textures
43. 7-1 Créer l\'armature
44. 7-2 Appliquer la symétrie du squelette
45. 7-3 Créer un contrôleur "Master"
46. 7-4 Créer une IK pour les jambes
47. 7-5 Créer une IK pour les bras
48. 7-6 Créer un contrôleur pour le regard
49. 7-7 Créer un contrôleur pour plier les doigts
50. 7-8 Appliquer les contrôleurs en symétrie
51. 7-9 Connecter l\'armature au personnage
52. 7-10 Customiser les contrôleurs genoux et coudes
53. 7-11 Customiser le contrôleur "Master"
54. 7-12 Customiser les contrôleurs IK
55. 7-13 Customiser les contrôleurs de la colonne vertébrale
56. 7-14 Customiser les contrôleurs épaules, cou, tête
57. 7-15 Appliquer des couleurs aux groupes de "bones"
58. 7-16 Customiser les contrôleurs des doigts
59. 7-17 Faire suivre le regard
60. 7-18 Automatiser la fermeture des doigts
61. 7-19 Créer des drivers pour plier les doigts
62. 7-20 Corrections de la fermeture du poing
63. 7-21 Réduire la résolution du pantalon en conservant les détails dans la texture
64. 7-22 Réduire la résolution du T-shirt en conservant les détails dans la texture
65. 7-23 Préparer le personnage pour éviter les éventuels défauts liés aux habits
66. 8-1 Créer les expressions faciales
67. 8-2 Fermer les yeux
68. 8-3 Créer un driver pour la fermeture des yeux
69. 8-4 Finaliser l\'expression de "colère" et lui créer un driver
70. 8-5 Faire briller les yeux
71. 9-1 Connecter les habits à l\'armature et peindre les influences des os
72. 9-2 Créer le "Kameha"
73. 9-3 Placer la première pose du personnage
74. 9-4 Créer le mouvement de caméra du premier plan de notre animation
75. 9-5 Affiner les réglages et faire sourire le personnage
76. 9-6 Animer le mouvement du personnage
77. 9-7 Correction bug possible de texture des yeux
78. 9-8 Animer le "Kameha"
79. 9-9 Placer et animer la 2ème caméra
80. 9-10 Créer l\'effet tremblement de la caméra
81. 9-11 Créer le mouvement des cheveux
82. 10-1 Créer le fond et les lumières
83. 10-2 Texturer le fond et régler la profondeur de champs des caméras
84. 10-3 Réglages de rendu
85. 10-4 Point sur l\'export et explications lumières volumétriques
79. 9-9 Placer et animer[xnmjklxx]la 2ème caméra
80. 9-10 Créer l\'effet tremblement de la caméra
81. 9-11 Créer le mouvement des cheveux
82. 10-1 Créer le[xwerrxxxxx]fond et les lumières
83. 10-2[xx]Texturer le fond et régler la profondeur de champs des caméras
84. 10-3 Réglages de rendu
85. 10-4 Point[xxxxtzzxxx]sur l\'export et explications '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end