#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\{\s*\"MapObject((?!MapObject)[\s\S])+\"Type\"\s*:\s*\"moReference(?:Point|Line)ID\"((?!MapObject)[\s\S])+},?\s*"
Local $sString = "[" & @CRLF & _
" {" & @CRLF & _
" "MapObject" : {" & @CRLF & _
" "BoundingBox" : [ -1313.574, -1010.804, -1113.574, -810.804 ]," & @CRLF & _
" "Caption" : "Ref46"," & @CRLF & _
" "Comment" : ""," & @CRLF & _
" "Position" : {" & @CRLF & _
" "CPosition" : [ -1213.574, -910.804, 0, 0 ]" & @CRLF & _
" }," & @CRLF & _
" "Size" : {" & @CRLF & _
" "CPosition" : [ 100, 100, 0, 0 ]" & @CRLF & _
" }," & @CRLF & _
" "Type" : "moReferencePointID"" & @CRLF & _
" }" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "MapObject" : {" & @CRLF & _
" "BoundingBox" : [ -1313.06, 495.39, -1113.06, 695.39 ]," & @CRLF & _
" "Caption" : "Ref47"," & @CRLF & _
" "Comment" : ""," & @CRLF & _
" "Position" : {" & @CRLF & _
" "CPosition" : [ -1213.06, 595.39, 0, 0 ]" & @CRLF & _
" }," & @CRLF & _
" "Size" : {" & @CRLF & _
" "CPosition" : [ 100, 100, 0, 0 ]" & @CRLF & _
" }," & @CRLF & _
" "Type" : "moReferencePointID"" & @CRLF & _
" }" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "MapObject" : {" & @CRLF & _
" "BoundingBox" : [ -18070, 1180, -17870, 1380 ]," & @CRLF & _
" "Caption" : "Path way84"," & @CRLF & _
" "Comment" : ""," & @CRLF & _
" "ExecutableMapObject" : {" & @CRLF & _
" "BehaviourList" : [" & @CRLF & _
" {" & @CRLF & _
" "Speed" : 200," & @CRLF & _
" "Type" : "bcSpeed"" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "AvoidanceSpeed" : 150," & @CRLF & _
" "FailureAction" : 0," & @CRLF & _
" "FailureRetries" : 60," & @CRLF & _
" "FailureWait" : 10," & @CRLF & _
" "PathMode" : 2," & @CRLF & _
" "PerSegment" : 15," & @CRLF & _
" "ReturnToStart" : 0," & @CRLF & _
" "ScanAngle" : 0.06981317007977778," & @CRLF & _
" "Type" : "bcObstacleAvoidance"," & @CRLF & _
" "Wait" : 10," & @CRLF & _
" "WaitUnits" : 2" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "BinarySensorStates" : 3," & @CRLF & _
" "SensorSensitivityList" : [" & @CRLF & _
" {" & @CRLF & _
" "IgnoreMapData" : false," & @CRLF & _
" "Mask" : 65536," & @CRLF & _
" "SpeedCapDistance" : 70," & @CRLF & _
" "SpeedCapEnabled" : true," & @CRLF & _
" "StopDistance" : 70" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "IgnoreMapData" : false," & @CRLF & _
" "Mask" : 131072," & @CRLF & _
" "SpeedCapDistance" : 70," & @CRLF & _
" "SpeedCapEnabled" : true," & @CRLF & _
" "StopDistance" : 70" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "IgnoreMapData" : false," & @CRLF & _
" "Mask" : 262144," & @CRLF & _
" "SpeedCapDistance" : 240," & @CRLF & _
" "SpeedCapEnabled" : true," & @CRLF & _
" "StopDistance" : 240" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "IgnoreMapData" : false," & @CRLF & _
" "Mask" : 524288," & @CRLF & _
" "SpeedCapDistance" : 240," & @CRLF & _
" "SpeedCapEnabled" : true," & @CRLF & _
" "StopDistance" : 240" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "IgnoreMapData" : false," & @CRLF & _
" "Mask" : 1048576," & @CRLF & _
" "SpeedCapDistance" : 240," & @CRLF & _
" "SpeedCapEnabled" : true," & @CRLF & _
" "StopDistance" : 240" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "IgnoreMapData" : false," & @CRLF & _
" "Mask" : 2097152," & @CRLF & _
" "SpeedCapDistance" : 280," & @CRLF & _
" "SpeedCapEnabled" : true," & @CRLF & _
" "StopDistance" : 280" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "IgnoreMapData" : false," & @CRLF & _
" "Mask" : 4194304," & @CRLF & _
" "SpeedCapDistance" : 320," & @CRLF & _
" "SpeedCapEnabled" : true," & @CRLF & _
" "StopDistance" : 320" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "IgnoreMapData" : false," & @CRLF & _
" "Mask" : 8388608," & @CRLF & _
" "SpeedCapDistance" : 0," & @CRLF & _
" "SpeedCapEnabled" : false," & @CRLF & _
" "StopDistance" : 0" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "IgnoreMapData" : false," & @CRLF & _
" "Mask" : 16777216," & @CRLF & _
" "SpeedCapDistance" : 0," & @CRLF & _
" "SpeedCapEnabled" : false," & @CRLF & _
" "StopDistance" : 0" & @CRLF & _
" }" & @CRLF & _
" ]," & @CRLF & _
" "SpeedCap" : 30," & @CRLF & _
" "Type" : "bcObstacleSensitivity2"" & @CRLF & _
" }" & @CRLF & _
" ]," & @CRLF & _
" "EntryPoint" : {" & @CRLF & _
" "CPosition" : [ -13450, 1290, 0, 0 ]" & @CRLF & _
" }," & @CRLF & _
" "ExitPoint" : {" & @CRLF & _
" "CPosition" : [ -17970, 1280, 0, 0 ]" & @CRLF & _
" }," & @CRLF & _
" "RelocateOnExecute" : false," & @CRLF & _
" "Required" : false," & @CRLF & _
" "TwoWay" : false" & @CRLF & _
" }," & @CRLF & _
" "GoalSet" : [" & @CRLF & _
" {" & @CRLF & _
" "Path" : {" & @CRLF & _
" "PathType" : "pitLinear"," & @CRLF & _
" "Segments" : [" & @CRLF & _
" {" & @CRLF & _
" "Segment" : [ -13450, 1290, -17970, 1280 ]" & @CRLF & _
" }" & @CRLF & _
" ]" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" ]," & @CRLF & _
" "Position" : {" & @CRLF & _
" "CPosition" : [ -17970, 1280, 0, 0 ]" & @CRLF & _
" }," & @CRLF & _
" "Size" : {" & @CRLF & _
" "CPosition" : [ 0, 0, 0, 0 ]" & @CRLF & _
" }," & @CRLF & _
" "Type" : "moLinePathID"" & @CRLF & _
" }" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "MapObject" : {" & @CRLF & _
" "AttributeList" : [" & @CRLF & _
" [ "Lock", "{} LabInt {}" ]" & @CRLF & _
" ]," & @CRLF & _
" "BoundingBox" : [ -12350, -500, -12150, -300 ]," & @CRLF & _
" "Caption" : "QUEUE/LabInt"," & @CRLF & _
" "Comment" : ""," & @CRLF & _
" "ExecutableMapObject" : {" & @CRLF & _
" "EntryPoint" : {" & @CRLF & _
" "CPosition" : [ -12250, -400, 0, 0 ]" & @CRLF & _
" }," & @CRLF & _
" "ExitPoint" : {" & @CRLF & _
" "CPosition" : [ -12250, -400, 0, 0 ]" & @CRLF & _
" }," & @CRLF & _
" "RelocateOnExecute" : false," & @CRLF & _
" "Required" : false," & @CRLF & _
" "TwoWay" : false" & @CRLF & _
" }," & @CRLF & _
" "Position" : {" & @CRLF & _
" "CPosition" : [ -12250, -400, 0, 0 ]" & @CRLF & _
" }," & @CRLF & _
" "Size" : {" & @CRLF & _
" "CPosition" : [ 100, 100, 0, 0 ]" & @CRLF & _
" }," & @CRLF & _
" "Type" : "moHotPointID"" & @CRLF & _
" }" & @CRLF & _
" }," & @CRLF & _
"]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")