import re
regex = re.compile(r"\{\s*\"MapObject((?!MapObject)[\s\S])+\"Type\"\s*:\s*\"moReference(?:Point|Line)ID\"((?!MapObject)[\s\S])+},?\s*")
test_str = ("[\n"
" {\n"
" \"MapObject\" : {\n"
" \"BoundingBox\" : [ -1313.574, -1010.804, -1113.574, -810.804 ],\n"
" \"Caption\" : \"Ref46\",\n"
" \"Comment\" : \"\",\n"
" \"Position\" : {\n"
" \"CPosition\" : [ -1213.574, -910.804, 0, 0 ]\n"
" },\n"
" \"Size\" : {\n"
" \"CPosition\" : [ 100, 100, 0, 0 ]\n"
" },\n"
" \"Type\" : \"moReferencePointID\"\n"
" }\n"
" },\n"
" {\n"
" \"MapObject\" : {\n"
" \"BoundingBox\" : [ -1313.06, 495.39, -1113.06, 695.39 ],\n"
" \"Caption\" : \"Ref47\",\n"
" \"Comment\" : \"\",\n"
" \"Position\" : {\n"
" \"CPosition\" : [ -1213.06, 595.39, 0, 0 ]\n"
" },\n"
" \"Size\" : {\n"
" \"CPosition\" : [ 100, 100, 0, 0 ]\n"
" },\n"
" \"Type\" : \"moReferencePointID\"\n"
" }\n"
" },\n"
" {\n"
" \"MapObject\" : {\n"
" \"BoundingBox\" : [ -18070, 1180, -17870, 1380 ],\n"
" \"Caption\" : \"Path way84\",\n"
" \"Comment\" : \"\",\n"
" \"ExecutableMapObject\" : {\n"
" \"BehaviourList\" : [\n"
" {\n"
" \"Speed\" : 200,\n"
" \"Type\" : \"bcSpeed\"\n"
" },\n"
" {\n"
" \"AvoidanceSpeed\" : 150,\n"
" \"FailureAction\" : 0,\n"
" \"FailureRetries\" : 60,\n"
" \"FailureWait\" : 10,\n"
" \"PathMode\" : 2,\n"
" \"PerSegment\" : 15,\n"
" \"ReturnToStart\" : 0,\n"
" \"ScanAngle\" : 0.06981317007977778,\n"
" \"Type\" : \"bcObstacleAvoidance\",\n"
" \"Wait\" : 10,\n"
" \"WaitUnits\" : 2\n"
" },\n"
" {\n"
" \"BinarySensorStates\" : 3,\n"
" \"SensorSensitivityList\" : [\n"
" {\n"
" \"IgnoreMapData\" : false,\n"
" \"Mask\" : 65536,\n"
" \"SpeedCapDistance\" : 70,\n"
" \"SpeedCapEnabled\" : true,\n"
" \"StopDistance\" : 70\n"
" },\n"
" {\n"
" \"IgnoreMapData\" : false,\n"
" \"Mask\" : 131072,\n"
" \"SpeedCapDistance\" : 70,\n"
" \"SpeedCapEnabled\" : true,\n"
" \"StopDistance\" : 70\n"
" },\n"
" {\n"
" \"IgnoreMapData\" : false,\n"
" \"Mask\" : 262144,\n"
" \"SpeedCapDistance\" : 240,\n"
" \"SpeedCapEnabled\" : true,\n"
" \"StopDistance\" : 240\n"
" },\n"
" {\n"
" \"IgnoreMapData\" : false,\n"
" \"Mask\" : 524288,\n"
" \"SpeedCapDistance\" : 240,\n"
" \"SpeedCapEnabled\" : true,\n"
" \"StopDistance\" : 240\n"
" },\n"
" {\n"
" \"IgnoreMapData\" : false,\n"
" \"Mask\" : 1048576,\n"
" \"SpeedCapDistance\" : 240,\n"
" \"SpeedCapEnabled\" : true,\n"
" \"StopDistance\" : 240\n"
" },\n"
" {\n"
" \"IgnoreMapData\" : false,\n"
" \"Mask\" : 2097152,\n"
" \"SpeedCapDistance\" : 280,\n"
" \"SpeedCapEnabled\" : true,\n"
" \"StopDistance\" : 280\n"
" },\n"
" {\n"
" \"IgnoreMapData\" : false,\n"
" \"Mask\" : 4194304,\n"
" \"SpeedCapDistance\" : 320,\n"
" \"SpeedCapEnabled\" : true,\n"
" \"StopDistance\" : 320\n"
" },\n"
" {\n"
" \"IgnoreMapData\" : false,\n"
" \"Mask\" : 8388608,\n"
" \"SpeedCapDistance\" : 0,\n"
" \"SpeedCapEnabled\" : false,\n"
" \"StopDistance\" : 0\n"
" },\n"
" {\n"
" \"IgnoreMapData\" : false,\n"
" \"Mask\" : 16777216,\n"
" \"SpeedCapDistance\" : 0,\n"
" \"SpeedCapEnabled\" : false,\n"
" \"StopDistance\" : 0\n"
" }\n"
" ],\n"
" \"SpeedCap\" : 30,\n"
" \"Type\" : \"bcObstacleSensitivity2\"\n"
" }\n"
" ],\n"
" \"EntryPoint\" : {\n"
" \"CPosition\" : [ -13450, 1290, 0, 0 ]\n"
" },\n"
" \"ExitPoint\" : {\n"
" \"CPosition\" : [ -17970, 1280, 0, 0 ]\n"
" },\n"
" \"RelocateOnExecute\" : false,\n"
" \"Required\" : false,\n"
" \"TwoWay\" : false\n"
" },\n"
" \"GoalSet\" : [\n"
" {\n"
" \"Path\" : {\n"
" \"PathType\" : \"pitLinear\",\n"
" \"Segments\" : [\n"
" {\n"
" \"Segment\" : [ -13450, 1290, -17970, 1280 ]\n"
" }\n"
" ]\n"
" }\n"
" }\n"
" ],\n"
" \"Position\" : {\n"
" \"CPosition\" : [ -17970, 1280, 0, 0 ]\n"
" },\n"
" \"Size\" : {\n"
" \"CPosition\" : [ 0, 0, 0, 0 ]\n"
" },\n"
" \"Type\" : \"moLinePathID\"\n"
" }\n"
" },\n"
" {\n"
" \"MapObject\" : {\n"
" \"AttributeList\" : [\n"
" [ \"Lock\", \"{} LabInt {}\" ]\n"
" ],\n"
" \"BoundingBox\" : [ -12350, -500, -12150, -300 ],\n"
" \"Caption\" : \"QUEUE/LabInt\",\n"
" \"Comment\" : \"\",\n"
" \"ExecutableMapObject\" : {\n"
" \"EntryPoint\" : {\n"
" \"CPosition\" : [ -12250, -400, 0, 0 ]\n"
" },\n"
" \"ExitPoint\" : {\n"
" \"CPosition\" : [ -12250, -400, 0, 0 ]\n"
" },\n"
" \"RelocateOnExecute\" : false,\n"
" \"Required\" : false,\n"
" \"TwoWay\" : false\n"
" },\n"
" \"Position\" : {\n"
" \"CPosition\" : [ -12250, -400, 0, 0 ]\n"
" },\n"
" \"Size\" : {\n"
" \"CPosition\" : [ 100, 100, 0, 0 ]\n"
" },\n"
" \"Type\" : \"moHotPointID\"\n"
" }\n"
" },\n"
"]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")