$re = '/RTL_433toMQTT\/([^\/:]+)\/([^\/:]+)\/([^\/:]+)[\/]?.*:.* /m';
$str = 'rtl433:home/rtl433/RTL_433toMQTT/Rubicson-Temperature/1/244:.* { json2nameValue($EVENT) }
rtl433:home/rtl433/RTL_433toMQTT/Nexus-TH/1/9:.* { json2nameValue($EVENT) }
rtl433:home/rtl433/RTL_433toMQTT/WT450-TH/1/1:.* { json2nameValue($EVENT) }
rtl433:home/rtl433/RTL_433toMQTT/Secplus-v1/0:.* { json2nameValue($EVENT) }
rtl433:home/rtl433/RTL_433toMQTT/Interlogix-Security/motion/485865:.* { json2nameValue($EVENT) }';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);