import Foundation
let pattern = #"RTL_433toMQTT\/([^\/:]+)\/([^\/:]+)\/([^\/:]+)[\/]?.*:.* "#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
rtl433:home/rtl433/RTL_433toMQTT/Rubicson-Temperature/1/244:.* { json2nameValue($EVENT) }
rtl433:home/rtl433/RTL_433toMQTT/Nexus-TH/1/9:.* { json2nameValue($EVENT) }
rtl433:home/rtl433/RTL_433toMQTT/WT450-TH/1/1:.* { json2nameValue($EVENT) }
rtl433:home/rtl433/RTL_433toMQTT/Secplus-v1/0:.* { json2nameValue($EVENT) }
rtl433:home/rtl433/RTL_433toMQTT/Interlogix-Security/motion/485865:.* { json2nameValue($EVENT) }
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)