// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)RTL_433toMQTT\/([^\/:]+)\/([^\/:]+)\/([^\/:]+)[\/]?.*:.* ").unwrap();
let string = "rtl433:home/rtl433/RTL_433toMQTT/Rubicson-Temperature/1/244:.* { json2nameValue($EVENT) }
rtl433:home/rtl433/RTL_433toMQTT/Nexus-TH/1/9:.* { json2nameValue($EVENT) }
rtl433:home/rtl433/RTL_433toMQTT/WT450-TH/1/1:.* { json2nameValue($EVENT) }
rtl433:home/rtl433/RTL_433toMQTT/Secplus-v1/0:.* { json2nameValue($EVENT) }
rtl433:home/rtl433/RTL_433toMQTT/Interlogix-Security/motion/485865:.* { json2nameValue($EVENT) }";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}