import re
regex = re.compile(r"^(?=[^A-Z\n]*[A-Z])(?=[^a-z\n]*[a-z])(?=[^0-9\n]*[0-9])(?=[^#?!@$%^&*\n-]*[#?!@$%^&*-]).{8,}$", flags=re.MULTILINE)
test_str = ("abcA1#!A\n"
"#!asdfSFD1;\n"
"# a f F1 ;\n"
"1111111111\n"
"aaaaaaaa\n"
"11111111\n"
"AAAAAAAA\n"
"########")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")