re = /^(?=[^A-Z\n]*[A-Z])(?=[^a-z\n]*[a-z])(?=[^0-9\n]*[0-9])(?=[^#?!@$%^&*\n-]*[#?!@$%^&*-]).{8,}$/m
str = 'abcA1#!A
#!asdfSFD1;
# a f F1 ;
1111111111
aaaaaaaa
11111111
AAAAAAAA
########'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end