using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^(\x00-\x7F,½)]";
string input = @"½ a b c d ! $ \ ~ ) _ + { } < > \r \n ⅓ ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}