$re = '/[^(\x00-\x7F,½)]/';
$str = '½ a b c d ! $ \\ ~ ) _ + { } < > \\r \\n ⅓ ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);