re = /Duração Relatório\s+\d[\d:.]+/
str = '584 +%put Duração Relatório &duracao.;
Duração Relatório 0:00:00.33'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end