// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"Duração Relatório\s+\d[\d:.]+").unwrap();
let string = "584 +%put Duração Relatório &duracao.;
Duração Relatório 0:00:00.33";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}