re = /robert (.+?) palmer(?:.* palmer)? sent for the boat/m
str = 'robert eric palmer sent for the boat
robert eric william palmer sent for the boat
robert eric palmer palmer sent for the boat
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end