// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)robert (.+?) palmer(?:.* palmer)? sent for the boat").unwrap();
let string = "robert eric palmer sent for the boat
robert eric william palmer sent for the boat
robert eric palmer palmer sent for the boat
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}