import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\w+(?:[\\.-]\\w+)*@\\w+(?:[\\.-]\\w+)*(?:\\.\\w{2,3})+$";
final String string = "valid-email-address@domain.com\n"
+ "very-very-very-long-and-invalid-email-address/@domain.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}