re = /^\w+(?:[\.-]\w+)*@\w+(?:[\.-]\w+)*(?:\.\w{2,3})+$/m
str = 'valid-email-address@domain.com
very-very-very-long-and-invalid-email-address/@domain.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end