$re = '/^\w+(?:[\.-]\w+)*@\w+(?:[\.-]\w+)*(?:\.\w{2,3})+$/m';
$str = 'valid-email-address@domain.com
very-very-very-long-and-invalid-email-address/@domain.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);