import re
regex = re.compile(r"(\d{4})(-?)(\d{4})(\2\d{4}){2}")
test_str = ("5123-4567-8912-3456\n"
"61234-567-8912-3456\n"
"4123356789123456\n"
"5133-3367-8912-3456")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")