re = /(\d{4})(-?)(\d{4})(\2\d{4}){2}/
str = '5123-4567-8912-3456
61234-567-8912-3456
4123356789123456
5133-3367-8912-3456'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end