import Foundation
let pattern = #"(\d{4})(-?)(\d{4})(\2\d{4}){2}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
5123-4567-8912-3456
61234-567-8912-3456
4123356789123456
5133-3367-8912-3456
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)