import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:;+)\\R*";
final String string = ";;;\n"
+ " z;\n"
+ "hh ;d;\n"
+ ";\n"
+ ";\n"
+ ";\n"
+ "12;b\n"
+ ";\n"
+ "bb;b\n"
+ ";;;\n"
+ ";;";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}