use strict;
my $str = ';;;
z;
hh ;d;
;
;
;
12;b
;
bb;b
;;;
;;';
my $regex = qr/^(?:;+)\R*/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";